Airsoft Canada
MILSIG

Go Back   Airsoft Canada > Discussion > Doctor's Corner
Home Forums Register Gallery FAQ Calendar
Retailers Community News/Info International Retailers IRC Today's Posts

KWA m93r semi auto not working

:

Doctor's Corner

Reply
 
Thread Tools Search this Thread
Old July 16th, 2012, 15:18   #1
Neurotrauma
 
Join Date: May 2011
KWA m93r semi auto not working

Just got a KWA m93r this morning and by the 2nd mag the semi auto function would only fire full auto. I did some research and it seems this is a common problem, I'm sending it back for now but I'm afraid it will have this issue again later, is there a home-fix for this?

Im surprised this would happen, i thought KWA was known for reliability but I didnt even get 3 mags out of it before it happened...
Neurotrauma is offline   Reply With Quote
Old July 16th, 2012, 16:03   #2
Foxer2373
 
Join Date: May 2011
The sear breaks! I'm suprised it broke that fast but if you consistently shoot on 3rd burst they break and only fires full auto(cause there is no sear to stop it) kwa is rear but because the guns shoot hotter than most parts lke that break easier than they should.

Had my m93r for 3 months of regular gaming and no issues so far but I only use semi or full auto.
Foxer2373 is offline   Reply With Quote
Old July 16th, 2012, 16:14   #3
Neurotrauma
 
Join Date: May 2011
so what happens when it breaks? is there a replacement part. how hard is it to replace a sear im new to GBBs.

I can still shoot 3 rnd burst just not semi...
Neurotrauma is offline   Reply With Quote
Old July 16th, 2012, 17:34   #4
coolman703
 
Join Date: Jul 2009
Location: Corner Brook, Newfoundland
Easy Fix!

Lightly pull the trigger on full auto :-P
__________________
C.Penney

Quote:
Originally Posted by m102404
Green gas has it's place...if you want to smell like one of those asian hello kitty/sailor moon shops.

We kitted up next to a guy who was using green gas once....we kept looking around for the 12yr old asian school girl until we figured out what it was.
coolman703 is offline   Reply With Quote
Old July 28th, 2012, 01:16   #5
zippomb
 
Join Date: Feb 2010
Location: Winnipeg
I have had the no semi issue for over a year and finally found a fix(thank You Ryan D). All it takes is some cardboard or plastic(credit card) and krazy glue. You could make it more permanent but i would rather the fix wear out rather than another part inside the gun.
1. Lay the gun on it's left side & remove the right grip panel, (two flat head screws)

2. Use an alcohol wipe or rubbing alcohol and a Q-tip to clean the area I'm pointing at with the screwdriver. (this same picture has the fix in place already)

3. Find or buy some superglue..... The thin liquid stuff not the gel kind. (I used the cheap stuff $1)

4. Open the glue package and while you're at it cut away a small strip of the compressed cardboard package backing the same width as the tab I've glued it to.

5. Use a drop of glue and glue the strip to the tab as shown in one of the pics......holding it in place for a good 20 seconds with a small flat head screwdriver. (Please note that in the pictures I'm just illustrating this as I have already got a piece glued in) (To clarify, use only one strip of the super glue package backing)

6. Cut off the excess
cardboard flush with metal tab and give the entire patch a coating of super glue. The thin super glue will wick into the paper/cardboard making it rigid and more wear resistant and also oil resistant.

7. Replace the right grip panel and enjoy!

After a few mags worth of use I would re-coat the patch with super glue as by now it will have worn a small notch into the patch and the extra coat will help seal the deal.
The only change I made to this was to use credit card plastic as I thought it would wear better. So far so good, I love having single shot again.
Attached Images
File Type: jpg IMG_6363Small.jpg (178.4 KB, 119 views)
zippomb is offline   Reply With Quote
Old July 28th, 2012, 06:48   #6
itairsoft
 
Join Date: May 2011
From offical KWA forum, someone posted a resolution regarding the shooting mode unreliability issue. It is not perfect but worth to take a look. It is a simple fix that require users to remove the metal bushing and he also attached a photo to identify the part.

If anyone has suggestion that can improve on the current simple fix, please share your valuable opinion.

Also, the credit card/card board fix is another genius solution to fix the issue. Thank you for sharing !

http://kwausa.com/forums/index.php?showtopic=9270
itairsoft is offline   Reply With Quote
ReplyTop


Go Back   Airsoft Canada > Discussion > Doctor's Corner

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Airsoft Canada
MILSIG

All times are GMT -4. The time now is 00:24.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2014, vBulletin Solutions, Inc.